martes, 12 de febrero de 2008

NO_PUBKEY

En ocasiones cuando añadimos en el /etc/apt/sources.list de nuestro Debian nuevas lineas al hacer apt-get update o aptitude update no encontramos con un error parecido a este:
W: GPG error: http://volatile.debian.org stable/volatile Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY EC61E0B0BBE55AB3
W: GPG error: http://volatile.debian.org stable/volatile-sloppy Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY EC61E0B0BBE55AB3
W: Tal vez quiera ejecutar 'apt-get update' para corregir estos problemas

Eso es porque el repositorio no es de total confianza. Para ello tenemos que agregar la clave "EC61E0B0BBE55AB3" (en este caso) en el listado de repositorios seguros.

Para ello, tendremos que escribir desde la línea de comandos:
gpg --keyserver subkeys.pgp.net --recv EC61E0B0BBE55AB3
gpg --export --armor KEY | apt-key add -

Después haz un aptitude update y verá que ya no tienes errores.